Site offline for routine maintenance
Incident Report for Centtrip
Resolved
Maintenance has been completed
Posted 12 months ago. Apr 20, 2018 - 22:59 UTC
Identified
We are currently undertaking scheduled updates and enhancements to our technology. The work will be complete by midnight, Friday 20th April. During this time, you will not be able to access your account online or via the app. Your Centtrip card is not affected and you can continue to use it as normal.

Thank you for your patience.
Posted 12 months ago. Apr 20, 2018 - 21:03 UTC