TECHNICAL ISSUE
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted Jan 09, 2023 - 14:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 09, 2023 - 13:01 UTC
Investigating
Your foreign exchange, payments, card loading and account transfer services are currently unavailable due to a technical issue. We apologise for any inconvenience and are working to resolve this as soon as possible.
Posted Jan 09, 2023 - 11:59 UTC
This incident affected: Account, API, and Integrations.