Order Cards issue
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted Mar 02, 2023 - 11:21 UTC
Investigating
We are currently investigating an issue where new card orders are using the Cardholder First Name / Last Name as the Name on Card, rather than the Emboss Name. This problem is present with the Card Issuer, so we are working with them to resolve as quickly as possible.
Posted Feb 28, 2023 - 17:47 UTC
This incident affected: Account.