Processor Issues
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 22, 2019 - 09:55 UTC
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jan 22, 2019 - 08:46 UTC
This incident affected: Account, API, and Integrations.