Processor Issues
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted 7 months ago. Jan 04, 2019 - 16:38 UTC
Investigating
We are currently investigating the issue with our third party processor.
Posted 7 months ago. Jan 04, 2019 - 15:14 UTC
This incident affected: Account, API, and Integrations.