UK/Europe card status delay
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted Oct 12, 2022 - 16:26 UTC
Identified
Centtrip cards are functioning normally, but there is a delay on card status changes displaying correctly.
Posted Oct 11, 2022 - 14:07 UTC
This incident affected: Account.