TECHNICAL ISSUE
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted Dec 06, 2023 - 17:42 UTC
Investigating
We are currently experiencing a technical issue which may affect your foreign exchange, payments, card loading and account transfer services. We apologise for the inconvenience and are working to resolve this as soon as possible.
Posted Dec 06, 2023 - 17:01 UTC
This incident affected: Account, API, and Integrations.