TECHNICAL ISSUE
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted Jan 19, 2023 - 11:19 UTC
Investigating
Your foreign exchange, payments, card loading and account transfer services are currently unavailable due to a technical issue. We apologise for any inconvenience and are working to resolve this as soon as possible.
Posted Jan 19, 2023 - 11:04 UTC
This incident affected: Account, API, and Integrations.