Processor Issues
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted 7 months ago. Jan 02, 2019 - 10:52 UTC
Investigating
We are currently investigating this issue.
Posted 7 months ago. Jan 02, 2019 - 09:40 UTC
This incident affected: Account, API, and Integrations.