Trading disabled
Incident Report for Centtrip
Resolved
Our payment service has resolved their issues, therefore trading has been enabled. We apologise for the inconvenience this may have caused.
Posted 8 months ago. Jul 10, 2018 - 08:25 UTC
Investigating
Our payment service is experiencing an outage, so we have disabled trading in the meantime. We will continue to update as we receive more information
Posted 8 months ago. Jul 10, 2018 - 08:04 UTC
This incident affected: Account, API, and Integrations.