Processor Issues
Incident Report for Centtrip
Resolved
This issue has now been resolved.
Posted 15 days ago. Mar 03, 2019 - 11:42 UTC
Investigating
We are currently investigating this issue.
Posted 15 days ago. Mar 03, 2019 - 10:03 UTC
This incident affected: Account, API, and Integrations.