TECHNICAL ISSUE
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted Jan 20, 2023 - 12:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 20, 2023 - 12:35 UTC
Investigating
Your foreign exchange services are currently unavailable due to a technical issue. We apologise for any inconvenience and are working to resolve this as soon as possible.
Posted Jan 20, 2023 - 11:57 UTC
This incident affected: Account, API, and Integrations.