Trading Disabled
Incident Report for Centtrip
Resolved
This incident has been resolved
Posted 11 months ago. May 21, 2018 - 08:14 UTC
Investigating
Our payment service is experiencing an outage, so we have disabled trading in the meantime. We will continue to update as we receive more information
Posted 11 months ago. May 21, 2018 - 08:01 UTC
This incident affected: Account, API, and Integrations.