TECHNICAL ISSUE
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted Dec 20, 2022 - 17:09 UTC
Monitoring
The technical issue affecting your foreign exchange, payments, card loading and account transfer services has now been resolved and you can use your account as normal. Thank you for your patience.
Posted Dec 20, 2022 - 15:28 UTC
Investigating
Your foreign exchange, payments, card loading and account transfer services are currently unavailable due to a technical issue. We apologise for any inconvenience and are working to resolve this as soon as possible.
Posted Dec 20, 2022 - 14:28 UTC
This incident affected: Account, API, and Integrations.