UK / EUROPE - Technical issue
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted Jul 05, 2022 - 16:39 UTC
Update
An update has been deployed to address a technical issue that was affecting your foreign exchange, payments, card loading and account transfer services. We are currently monitoring this to ensure your service resumes as normal.
Posted Jul 05, 2022 - 15:12 UTC
Monitoring
An update has been deployed to address a technical issue that was affecting your foreign exchange, payments, card loading and account transfer services. We are currently monitoring this to ensure your service resumes as normal.
Posted Jul 05, 2022 - 15:12 UTC
Investigating
We are currently experiencing a technical issue which may affect your foreign exchange, payments, card loading and account transfer services. We apologise for the inconvenience and are working to resolve this as soon as possible.
Posted Jul 05, 2022 - 12:20 UTC
Monitoring
An update has been deployed to address a technical issue that was affecting your foreign exchange, payments, card loading and account transfer services. We are currently monitoring this to ensure your service resumes as normal.
Posted Jul 05, 2022 - 12:17 UTC
Investigating
We are currently experiencing a technical issue which may affect your foreign exchange, payments, card loading and account transfer services. We apologise for the inconvenience and are working to resolve this as soon as possible.
Posted Jul 05, 2022 - 10:05 UTC
This incident affected: Account.