UK / EUROPE - Technical issue - Intermittent delays displaying card transactions.
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted Apr 09, 2022 - 11:50 UTC
Update
We are continuing to investigate this issue.
Posted Apr 09, 2022 - 11:49 UTC
Update
We are continuing to investigate this issue.
Posted Apr 08, 2022 - 15:08 UTC
Investigating
We are currently experiencing intermittent card transaction delays. You may not see card transactions immediately. Balances will update accurately.
Posted Apr 08, 2022 - 09:29 UTC
This incident affected: Account, API, and Integrations.