Mobile App Login Issues
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 09:36 UTC
Investigating
We are currently investigating an issue preventing users from logging in to the Centtrip mobile app. Please use a web browser to access your account in the meantime.
Posted Nov 20, 2023 - 08:35 UTC
This incident affected: Integrations.