Trading disabled
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted 3 months ago. Feb 22, 2019 - 08:59 UTC
Investigating
We are currently investigating this issue with our processor and have disabled user functionality while we resolve the issue.
Posted 3 months ago. Feb 22, 2019 - 08:35 UTC
This incident affected: Account, API, and Integrations.