Trading disabled
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted 6 months ago. Jan 31, 2019 - 11:41 UTC
Monitoring
A fix has been implemented by our payment service and we are monitoring the results.
Posted 6 months ago. Jan 31, 2019 - 11:40 UTC
Investigating
Our payment service is experiencing an outage, so we have disabled trading in the meantime. We will continue to update as we receive more information
Posted 6 months ago. Jan 31, 2019 - 10:55 UTC
This incident affected: Account, API, and Integrations.