Trading Disabled
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted 6 months ago. Jan 28, 2019 - 08:29 UTC
Update
We are continuing to investigate this issue.
Posted 6 months ago. Jan 28, 2019 - 08:18 UTC
Update
We are continuing to investigate this issue.
Posted 6 months ago. Jan 28, 2019 - 08:18 UTC
Investigating
Our payment service is experiencing an outage, so we have disabled trading in the meantime. We will continue to update as we receive more information
Posted 6 months ago. Jan 28, 2019 - 08:17 UTC
This incident affected: Account, API, and Integrations.