Trading issues with Currency Provider
Incident Report for Centtrip
Resolved
Issue has been resolved, therefore trading has been enabled
Posted over 1 year ago. Apr 27, 2018 - 08:58 UTC
Investigating
We have been notified by our Currency provider that they are experiencing issues and, as a precaution, we have disabled trading temporarily.
Posted over 1 year ago. Apr 27, 2018 - 08:12 UTC