Processor issues
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted 3 months ago. Feb 01, 2019 - 10:33 UTC
Investigating
We are currently investigating this issue.
Posted 3 months ago. Feb 01, 2019 - 10:29 UTC
This incident affected: Account, API, and Integrations.