Processor Issues
Incident Report for Centtrip
Resolved
This incident has been resolved.
Posted 2 months ago. Mar 08, 2019 - 12:59 UTC
Investigating
We are currently investigating this issue.
Posted 2 months ago. Mar 08, 2019 - 12:33 UTC
This incident affected: Account, API, and Integrations.